Flexera One - IT Asset Management - NA - Delay in Task Processing
Incident Report for Flexera System Status Dashboard
Postmortem

Description:  Flexera One - IT Asset Management - NA - Delay in Task Processing

Timeframe:  March 20th, 1:00 PM to March 21st, 4:47 PM PDT

Incident Summary

On Wednesday, March 20th, at 1:00 PM PDT, we experienced a service interruption with the IT Asset Management service followed by a scheduled change which caused a processing backlog in the environment. As a result, some customers in the North America region may have experienced delays in their jobs being processed.

Upon detecting the issue, our technical teams immediately started their investigation and identified the cause of the delay. The delay was attributed to an inadvertent pause in the schedule for batch processes during a scheduled update, leading to a backlog of tasks that needed to be processed once the scheduler resumed normal operation.

The technical team confirmed that the scheduler had been resumed, leading to a reduction in the backlog queue since its resumption. However, we continued to monitor the environment to ensure the successful processing of the backlog for complete resolution. On March 21st, at 4:47 PM PDT, our technical team verified that the queue had returned to normal levels, indicating the successful resolution of the incident.‌

Root Cause

The delay was attributed to an inadvertent pause in the schedule for batch processes during a scheduled update, leading to a backlog of tasks that needed to be processed once the scheduler resumed normal operation.

Remediation Action

Our technical teams successfully resumed the scheduler, allowing jobs to resume processing promptly. This action effectively reduced the backlog, which was subsequently cleared after a short period of time.‌

Future Preventative Measure

Improve Documentation and Training: We acknowledge the unintentional action of pausing the scheduler during the scheduled update and commit to enhancing documentation and training procedures to ensure accurate management of scheduling tasks in the future.

Posted Apr 11, 2024 - 22:24 PDT

Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 16:55 PDT
Monitoring
Incident Description: We are currently experiencing delays in task processing following a scheduled change last evening. Users may encounter delays in the processing of tasks submitted during this timeframe. This delay is due to batch server downtime, resulting in a backlog in task processing.

Priority: P2

Restoration Activity: The delay in processing was due to a scheduling issue that occurred during yesterday's evening change. Processing was resumed shortly after, and we anticipate clearing the backlog within the next few hours. We apologize for any inconvenience caused and appreciate your patience as we work to restore normal operations.
Posted Mar 21, 2024 - 10:26 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Batch Processing System).