Flexera One UI - NA - Experiencing Performance Delays
Incident Report for Flexera System Status Dashboard
Postmortem

Description: Flexera One UI - NA - Performance Delays

Timeframe:

• May 1st, 1:01 AM to May 1st, 1:21 AM PDT
• May 2nd, 4:36 PM to May 2nd, 4:46 PM PDT

Incident Summary

On Wednesday, May 1st, 2024, at 1:01 AM PDT, we identified service degradation affecting the Flexera One UI in the North America region, resulting in slower response times for users attempting to log in to Flexera One. Additionally, attempts to generate the token for using the API may have resulted in failures.

Our investigation determined that the issue was intermittent and occurred for a brief period. The last occurrence was observed at 1:21 AM PDT on that day; however, we continued monitoring for several hours to ensure the platform's stability.

The next day, Thursday, May 2nd, we again observed performance degradation during our regular monitoring. This time, the issue was also intermittent, with performance problems lasting between 4:36 PM and 4:46 PM PDT.

We resumed extended monitoring, and with no further issues observed, the incident was declared resolved.

Root Cause

Our technical teams are actively engaged in determining the underlying cause and are collaborating with the service provider as well. The service provider observed a sudden increase in system resource usage, which coincided with the incident on May 1st. However, we have yet to establish a definitive correlation between these observations and our performance issues.

Remediation Actions

  1. Established Immediate Contact with Service Provider: Our team promptly initiated communication with the service provider upon detecting the issue, initiating collaborative efforts to address the performance degradation.
  2. Maintained Monitoring: Continuous monitoring was upheld to track the performance of the Flexera One UI, ensuring any recurrence of the degradation was promptly identified and addressed.
  3. Conducted Health Checks: Comprehensive health checks were conducted across the Flexera One platform to verify stability and performance restoration.

Future Preventative Measures

  1. Collaborative Analysis: Our technical team has provided logs to the service provider for thorough investigation and analysis. While we have not observed any recurrence recently, we maintain continuous communication with them to ensure proactive approach to the problem.
  2. Problem Management Investigation: This incident has transitioned to a problem management investigation. Our technical teams are actively investigating and isolating the underlying issue. We are committed to ensuring continued stability and will develop long-term measures based on our findings.
Posted May 15, 2024 - 13:50 PDT

Resolved
We have not encountered any further occurrences, and the services have continued to function as anticipated. Subsequently, this incident has been resolved.
Posted May 01, 2024 - 08:48 PDT
Monitoring
Incident Description: We received reports of service degradation affecting the Flexera One UI in the NAM region, resulting in slower response times for users attempting to log in to Flexera One. Additionally, any attempts to generate the token to use the API would have resulted in failures.

Priority: P2

Restoration Activity: The issue has been identified and resolved on our vendor's side. However, it occurred intermittently overnight. Normal operations have been restored, and there have been no further occurrences since around 1:21 AM PDT. As a precautionary measure, we are monitoring the environment for an extended period to ensure sustained stability.
Posted May 01, 2024 - 06:20 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Beacon Communication, IT Asset Management - US Inventory Upload, IT Asset Management - US Login Page, IT Asset Management - US Batch Processing System, IT Asset Management - US Business Reporting, IT Asset Management - US SaaS Manager, IT Asset Management - US Restful APIs), Flexera One - IT Visibility - North America (IT Visibility US), Flexera One – APIs – North America (api.flexera.com), and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US, Cloudscape).